Help, my game won't download or install!

We know you are excited to play. The first thing you will need to check and see is if your device can run the game. You can view the minimum requirements below!

MINIMUM DESKTOP REQUIREMENTS:

  • Requires a 64-bit processor and operating system
  • Operating System:
    • (Windows) Windows 7 with Service Pack 1 and up (64 bits)
    • (Mac) High Sierra 10.13+
  • Memory: 4 GB RAM
  • Graphics: Radeon 7000 Series and up
  • Storage: 2 GB available space

Fer.al is only available for Windows and Mac PC/Laptops. Linux systems and Chromebooks are currently not supported and will be unable to run the game.

MINIMUM MOBILE REQUIREMENTS:
*You must be on a strong wi-fi network. This game will not work with Cellular data.*

Android: (Unfortunately there are far too many Android devices to list them all!)

  • Device version of 10 or higher 
  • Compatible with the Vulkan API
  • At least 4GB of RAM should work.

Apple:

  • Any device that can run iOS 13 or greater



If your device meets the minimum requirements listed but you are still unable to download or install the game, submit a support ticket below by clicking the link here: Support Help

Was this article helpful?
290 out of 767 found this helpful

For billing or technical assistance, please submit a request . For any other inquiry, please visit our Discord.